Advice and answers from the Device Magic Team

Original Device Magic app UI:

  • Android 2.2 and above
  • Blackberry 4.6.1 and above (5.0 and above is recommended)
  • iOS 8.0 and above
Did this answer your question?