Below is a list of the Android OS versions which Device Magic is compatible with.

New Device Magic iOS app UI:

  • iOS 9.1 and above.


Original Device Magic iOS app UI:

  • iOS 8.0 and above.


Did this answer your question?