Below is a list of the Android OS versions which Device Magic is compatible with.

New Device Magic App UI:

  • Android 4.1 (Jelly Bean) and above.

Original Device Magic App UI:

  • Android 2.2 (Froyo) and above.

Did this answer your question?